Struggling to get Sample Application to work with AdventureWork2008R2 DB....???

Sep 21, 2012 at 10:45 AM
Edited Sep 21, 2012 at 10:48 AM

Hi,

I am trying to get the sample app working. I am using SQL Server 2008(10.50.2500) so installed the AdventuresWorks2008R2 OLTP database. I now realise that the tables are different. Which AW database should I be installing? May be worth having a link from the download page for the sample app. There does seem to be multiple versions of AW.

I am also getting interesting errors like the table "Customer_Individual" does not exist. I guess this derived from Individual inheriting from Customer in the Entity Model.

Many thanks,

Ed

Coordinator
Sep 21, 2012 at 3:30 PM

Does this one work ? 

http://msftdbprodsamples.codeplex.com/downloads/get/478216

Yes we should probably reference directly from the downloads page

 

 

Sep 21, 2012 at 4:07 PM

Hi,

Thanks for the reply.

This was the first version that I tried, and it did not work. It was complaining about missing "Customer_Individual" tables etc. I have looked at the code which was interesting, but it seems for whatever reason that the Sample app is now not working.

Thanks,

Ed

Sep 21, 2012 at 4:08 PM

I also tried the AdventureWorks2008 DB and still no joy. Has this Sample app been built with the AdventureWorks2005 DB? I cannot find it to download, it is not on Codeplex as far as I can see.

Ed

Editor
Sep 21, 2012 at 4:14 PM
I remember similarly fiddling about. Looking at what's on my disk, I seem to have AdventureWorks2008R2_RTM.exe, which might be the one that worked for me.

Contact me offline and I'll point you to a link for it.

Dan

On 21 September 2012 16:08, ESSB <notifications@codeplex.com> wrote:

From: ESSB

I also tried the AdventureWorks2008 DB and still no joy. Has this Sample app been built with the AdventureWorks2005 DB? I cannot find it to download, it is not on Codeplex as far as I can see.

Ed

Read the full discussion online.

To add a post to this discussion, reply to this email (nakedobjects@discussions.codeplex.com)

To start a new discussion for this project, email nakedobjects@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Coordinator
Sep 21, 2012 at 5:03 PM
Edited Sep 21, 2012 at 5:07 PM

Yes the schema seems to have changed in the 2008R2 database

I think we originally used the 2005 AW database (http://msftdbprodsamples.codeplex.com/releases/view/4004)

I also think in the next release we should probably move the sample onto the latest 2012 database.

 

 

Sep 21, 2012 at 5:14 PM

Aaah.... I understand. Will give this a try.

Thanks,

Ed

Sep 21, 2012 at 5:32 PM

Thanks, that sorted it. Now working.

Thanks,

Ed

Editor
Sep 21, 2012 at 5:35 PM

Good-o.

Sorry to be brief, sent from my phone

On Sep 21, 2012 5:32 PM, "ESSB" <notifications@codeplex.com> wrote:

From: ESSB

Thanks, that sorted it. Now working.

Thanks,

Ed

Read the full discussion online.

To add a post to this discussion, reply to this email (nakedobjects@discussions.codeplex.com)

To start a new discussion for this project, email nakedobjects@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com