Having issues with getting "ActionOrder" attribute to work.......

Sep 19, 2012 at 4:40 PM

Hi,

 

Just experimenting with this. I was expecting these methods to be inserted into the menu, but they were not.

   [ActionOrder("Step1, Step2")]
    public partial class Customer
    {
 
            public void Step1() { int i = 0; i = i++ ; }
            public void Step2() { int i = 0; i = i++; }
            public void Step3() { int i = 0; i = i++; }
            public void Step4() { int i = 0; i = i++; }

    }

Any ideas please?

Many thanks.

Sep 19, 2012 at 4:45 PM

Sorry, just found it under the "Actions" button.... Doh!!! I'm getting there.......

Editor
Sep 19, 2012 at 4:47 PM
Better is to use the [MemberOrder(...)] attribute. This applies both to actions and also to properties/collections. For the latter, you need to add the attribute in the metadata "buddy" class (will override the metadata generated by T4 template).


On 19 September 2012 16:45, ESSB <notifications@codeplex.com> wrote:

From: ESSB

Sorry, just found it under the "Actions" button.... Doh!!! I'm getting there.......

Read the full discussion online.

To add a post to this discussion, reply to this email (nakedobjects@discussions.codeplex.com)

To start a new discussion for this project, email nakedobjects@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com